Clover is experiencing an issue with transactions showing on the Merchant Dashboard

Incident Report for External Clover Status Page

Resolved

The issue has been resolved, and all Clover systems are working as expected. If you need further assistance, please contact Clover support. Thank you again for your patience while we worked through this issue.
Posted Jul 08, 2025 - 12:48 PDT

Update

We continue to investigate the issue and appreciate your patience.
Posted Jul 08, 2025 - 11:26 PDT

Investigating

We're investigating an issue impacting Clover merchants in the EU. Transactions are processing successfully, but are delayed in appearing on your Merchant Dashboard. Additionally, refunds are unsuccessful and will need to be attempted again later. Our team is actively working on a resolution. We appreciate your patience and will provide an update in 30 minutes.
Posted Jul 08, 2025 - 10:41 PDT
This incident affected: Europe - Clover Services (Dashboard).